kevin preguntado en EducaciónAyuda con los estudios · hace 2 años

¿Análisis para implementarlo en Pseint?

hola soy estudiante de primer ciclo en sistemas y me mandaron a hacer en pseint lo siguiente: Hacer un algoritmo que calcule cuantos días han pasado desde de tal fecha hasta la fecha actual (en mi caso cuantos días ha pasado desde mi cumpleaños, hasta la fecha actual) porfa he estado intentandolo pero no doy con el analisis del problema, gracias.

1 respuesta

Calificación
  • hace 2 años

    Proceso sin_titulo

    escribir "Ingrese primera fecha"

    escribir Sin Saltar "Año: "

    leer aa

    escribir Sin Saltar "Mes: "

    leer ma

    escribir Sin Saltar "Dias: "

    leer da

    escribir "Ingrese segunda fecha"

    escribir Sin Saltar "Año: "

    leer an

    escribir Sin Saltar "Mes: "

    leer mn

    escribir Sin Saltar "Dias: "

    leer dn

    si da>dn Entonces

    dias=da-dn

    Sino

    si ma=1 o ma=3 o ma=5 o ma=7 o ma=8 o ma=10 o ma=12 Entonces

    dias=31+da-dn

    ma=ma-1

    Sino

    si ma=4 o ma=6 o ma=9 o ma=11 Entonces

    dias=30+da-dn

    ma=ma-1

    Sino

    si aa%4=0 Entonces

    dias=29+da-dn

    ma=ma-1

    Sino

    da=28+da-dn

    ma=ma-1

    FinSi

    FinSi

    FinSi

    FinSi

    si ma>=mn Entonces

    meses=ma-mn

    Sino

    meses=12+ma-mn

    aa=aa-1

    FinSi

    años=aa-an

    escribir "Hay " años "años, " meses "meses y " dias "dias de diferencia entre las fechas"

    FinProce

    Fuente(s): Pregunta de hace 5 años en Yahoo R
¿Aún tienes preguntas? Pregunta ahora para obtener respuestas.