Mary
Lv 6

¿Función Logica de Excel?

Esta es la formula que tengo

=SI(($A$2:$A$6),MAX($B$2:$B$6),"no aplica")

El problema es que calcula nada mas el máximo, colocando el numero máximo pero ignorando, el tercer valor

¿Como hacer que los valores menores se pongan en "no aplica"

2 respuestas

Calificación
  • hace 7 años
    Respuesta preferida

    Hola, Mary.

    Es como dice Javier: El primer argumento debe establecer una condición. Excel evalúa si esa condición se cumple o no y si se cumple lleva a cabo el segundo argumento; si no se cumple, lleva a cabo el tercer argumento.

    Como el rango que establecés como primer argumento no tiene ninguna celda vacía, Excel lo considera verdadero y siempre da como resultado el segundo argumento. Por eso nunca muestra el tercero.

    Debés cambiar la condición.

    Espero haberte ayudado.

    Te invito a visitar http://clasesexcel.com/ para obtener más trucos e información sobre Excel y suscribirte al boletín gratuito.

    Saludos

  • Javier
    Lv 6
    hace 7 años

    No veo por ningún lado que apliques la sintasis de la función SI, que es la siguiente:

    Sintaxis: SI(prueba_lógica, [valor_si_verdadero], [valor_si_falso])

    La expresión $A$2:$A$6 solo determina un campo, falta la condición que debe cumplir para devolver verdadero (TRUE) o falso (FALSE).

¿Aún tienes preguntas? Pregunta ahora para obtener respuestas.