¿Función Logica de Excel?

Esta es la formula que tengo

=SI(($A$2:$A$6),MAX($B$2:$B$6),"no aplica")

El problema es que calcula nada mas el máximo, colocando el numero máximo pero ignorando, el tercer valor

¿Como hacer que los valores menores se pongan en "no aplica"

2 respuestas

Calificación
  • hace 7 años
    Respuesta preferida

    Es que tu función está mal diseñada.

    La parte del SI siempre se cumple cuando existan datos en el rango A2 a A6, por eso siempre que existan datos en A2:A6, se pinta MAX (el valor para true )y no el 'no aplica'

    ¿Cual es el requerimiento que deseas solucionar?

    En el rango A2:A6, parece ser que A3 es obligatorio tenga un número para que se cumpla el 'SI' (cuando true = despliega MAX)

    Attachment image
    Fuente(s): Aquí algunas guías rápidas para manejo de Excel> http://j.mp/1uqsD8F
  • hace 7 años

    Hola, Mary.

    Es como dice wakaMXwaka: El primer argumento debe establecer una condición. Excel evalúa si esa condición se cumple o no y si se cumple lleva a cabo el segundo argumento; si no se cumple, lleva a cabo el tercer argumento.

    Como el rango que establecés como primer argumento no tiene ninguna celda vacía, Excel lo considera verdadero y siempre da como resultado el segundo argumento. Por eso nunca muestra el tercero.

    Debés cambiar la condición.

    Espero haberte ayudado.

    Te invito a visitar http://clasesexcel.com/ para obtener más trucos e información sobre Excel y suscribirte al boletín gratuito.

    Saludos

¿Aún tienes preguntas? Pregunta ahora para obtener respuestas.