¿hacer los siguientes algoritmos?

1- que halle la cantidad la cantidad de numeros impares de 15 digitos?

2- hacer un algoritmo que halle la sumatoria de los 15 primeros numeros pares?

Actualización:

en seudocodigo gracias

4 respuestas

Calificación
  • Eric
    Lv 4
    hace 8 años
    Respuesta preferida

    ALGORITMO 2

    inicio

    entero suma, i

    para(i=0;i<=15;i=i+2)

    sum=sum+i;

    fin_para

    imprime("La sumatoria es: ", suma)

    fin

    AL PRIMERO NO LE ENTENDI MUY BIEN

  • ?
    Lv 6
    hace 8 años

    Hola.

    1-

    Proceso cni15d

    Definir c Como Entero

    c<-0

    para i<-111111111111111 hasta 999999999999999 Con Paso 2

    c<-c+1

    FinPara

    Escribir "Hay ",c,"impares de 15 cifras"

    FinProceso

    // número de 15 dígitos por ejemplo " 345876976521345" ¿cuantos de estos impares? supongo que eso preguntantes.

    2-

    Proceso snp15p

    definir s Como Entero

    s<-0

    para i<-2 hasta 30 Con Paso 2 Hacer

    Mostrar Sin Saltar i," "

    s<-s+i

    FinPara

    Mostrar ""

    Mostrar "la sumatoria es ",s

    FinProceso

    ------------------------------------------

    *** Ejecución Iniciada. ***

    2 4 6 8 10 12 14 16 18 20 22 24 26 28 30

    la sumatoria es 240

    *** Ejecución Finalizada. ***

    Saludos.

  • hace 8 años

    Para el primero es muy sencillo...

    1.Pedir los 15 dijitos

    c=0;

    numero=0;

    leer(Escribe 15 dijitos)

    Para (i=0,i<15,i++)

    Escribir(numero)

    si(numero%2==1)

    c++;

    fin de para

    leer("la cantidad de numero par son: " + numero )

    2.El segundo es muy parecido

    suma=0;c=0;

    mientras(cont<=15)

    if(c%2 ==0)

    suma+=c

    cont++

    fin si

    c++

    fin mientras

    leer(la suma es"+ suma)

  • Anónimo
    hace 8 años

    es en pseudocodiogo o en lenguaje de programación y cual? ..ok!

    al frente pondré algunos comentarios para que puedas entender que es lo que se esta haciendo.

    1-

    Inicio

    tipo entero cantidad, valor, x //declaración de variables

    para (x=1;x<=15;x=x+1)

    Escriba "Ingrese un numero"

    lea valor

    si (valor%2=1) //esto indica que si el numero ingresado es impar

    entonces

    cantidad=cantidad + 1 //adiciona a la cantidad si el numero es impar

    Escriba "La cantidad de números impares es " cantidad

    finsi

    fin para

    Fin

    ________________________________________________________

    2-

    Inicio

    tipo entero valor, suma, contador

    Escriba "Ingrese un numero"

    lea valor

    Haga mientra valor <> "999" //hace mientras valor es diferente de 999

    si(valor%2=0)

    suma=suma+valor //aqui se realiza la suma del par ingresado

    contador=contador+1 //cuenta los numeros pares que debe sumar

    finsi

    Escriba "Ingrese un numero" //porque ciclo no va a terminar hasta encontrar 15 valores pares

    lea valor

    si (contador=15) //si contador = a 15

    entonces

    valor="999" //hace valor = 999 para romper el ciclo

    finsi

    fin mientras

    Escriba "La sumatoria de los 15 primeros números pares es " suma //muestra cual es la suma

    Fin

    Bueno espero te sirva, Saludos.

    Fuente(s): soy estudiante de programación
¿Aún tienes preguntas? Pregunta ahora para obtener respuestas.