¿ayuda urgente borland c++?

Hola, sinceramente necesito que me ayuden con estos ejercicios..todos me los pusieron en un examen(recién empecé a trabajar con el programa), el profe con el que llevo algoritmos nos dijo que si los resolvíamos, nos subiría puntos en el examen...asi que por favor ayúdenme

Estos son los ejercicios:

1.- Convertir un monto ingresado en nuevos soles en billetes de 20, 10,monedas de 5, 2 y 1 sol; y para los decimales en monedas de 0.50, 0.20, 0.10 y 0.05 céntimos

2.- El precio de las memorias USB tienen descuentos según la marca: Kingston 10%, Sony 15%, Sentinel 20%, Kodak 25% y Mirray 30%. Se debe adquirir por lo menos 2 productos de marca distinta. Mostrar el importe bruto, descuento e importe por la marca

3.- El gobierno ha implementado como parte de su programa inclusión social, un subsidio familiar bajo la sgte. forma:

a.-Las familias que tienen hasta 2 hijos reciben S/200.00, las que tienen entre 3 a 5 hijos reciben S/300.00 y las que tienen 6 hijos reciben S/500.00

b.- Por cada hijo en edad escolar reciben S/50 soles adicional. Se considera edad escolar entre 6 y 18 años

c.-Si la madre fuera viuda, la familia recibe S/50 adicionales.

Determinar el monto mensual que recibirá una familia de acuerdo a su propia realidad familiar

Tengan en cuenta que recién estoy empezando en c++ quizás algunos lo vean sencillo los problemas, pero igual necesito su ayuda..les agradecería mucho (si es posible necesito las resoluciones para mañana)

2 respuestas

Calificación
  • hace 8 años
    Respuesta preferida

    Si sos principiante primero deberías hacer que antes pasar el código c++ aprende al Pseudocodigo antes de empezar a programas. Te voy dar un ejemplo depende de ti como sigue con los demás.

    contador<-1;

    HACER

        ESCRIBIR "Cual es la marca del pendrive";

        LEER marca;

        ESCRIBIR "El precio";

        LEER precio;

        SI marca="Kingston" ENTONCES

            descuento<-descuento+(precio*0.1);

        SINO

            SI marca="SONY" ENTONCES

                descuento<-descuento+(precio*0.15);

            SINO

               SI marca="SENTINEL" ENTONCES

                   descuento<-descuento+(precio*0.2);

               SINO

    Asi con los demas

           FINSI

        FINSI

        FINSI

       suma<-suma+precio

       contador<-contador+1;

       ESCRIBIR "Desea comprar otro pendrive";

       LEER respuesta;

    MIENTRAS respuesta="si"

    ESCRIBIR "El total es ",suma;

    ESCRIBIR "El descuento total esx ",descuento;

    Algo asi abrazo

  • hace 4 años

    Un ejemplo: #contain<conio.h> #contain<stdio.h> #contain<iostream.h> /* Inicio del programa critical */ int substantial () //Funcion critical del programa { textbackground(WHITE); clrscr(); textcolor(purple+BLINK); gotoxy(30,a million); cprintf("CURRICULUM VITAE"); textcolor(BLACK); gotoxy(5,2); cprintf("Nombre: goyo xxxxxxxx"); gotoxy(5,4); cprintf("Edad: 17 a¤os"); gotoxy(5,6); cprintf("Direccion: Rio Frio Finca 4 de l. a. iglesia catolica a hundred mts oeste y 10mts sur"); gotoxy(5,8); cprintf("Escuela de Procedencia: Centro educativo de Finca 4"); gotoxy(5,10); cprintf("Colegio de Procedencia: Liceo de Rio Frio"); gotoxy(5,12); cprintf("Universidad: xxxx"); gotoxy(5,14); cprintf("Experiencia Laboral: Ense¤ansas de html y own abode page"); gotoxy(5,sixteen); cprintf("Referencia:Falkudivers"); gotoxy(5,18); cprintf("XD termine"); getch(); clrscr(); getch(); gotoxy(30,a million); cprintf("CURRICULUM VITAE"); textcolor(BLACK); gotoxy(5,2); cprintf("Nombre: goyo xxxxxxxx"); gotoxy(5,4); cprintf("Edad: 17 a¤os"); gotoxy(5,6); cprintf("Direccion: Rio Frio Finca 4 de l. a. iglesia catolica a hundred mts oeste y 10mts sur"); gotoxy(5,8); cprintf("Escuela de Procedencia: Centro educativo de Finca 4"); gotoxy(5,10); cprintf("Colegio de Procedencia: Liceo de Rio Frio"); gotoxy(5,12); cprintf("Universidad: xxxx"); gotoxy(5,14); cprintf("Experiencia Laboral: Ense¤ansas de html y own abode page"); gotoxy(5,sixteen); cprintf("Referencia:Falkudivers"); gotoxy(5,18); cprintf("XD termine"); getch(); return(0); }

¿Aún tienes preguntas? Pregunta ahora para obtener respuestas.